On Fri, 11 Sep 2026 21:41:30 +0000 Asbjørn Sloth Tønnesen wrote:
Correct the names of these `enum netkit_action` constants:
- NETKIT_PASS is 0, so "pass", not "forward".
- NETKIT_DROP is 2, so "drop", not "blackhole".
Note, the other enum members are not used in netlink, and
are not allowed by netkit_check_policy().
Looks right tho may be intentional, so the other option would be to add
#define aliases for the spec names.
CC: Nik and Daniel
quoted hunk ↗ jump to hunk
diff --git a/Documentation/netlink/specs/rt-link.yaml b/Documentation/netlink/specs/rt-link.yaml
index ac2084d14f22..e8af962c8064 100644
--- a/Documentation/netlink/specs/rt-link.yaml
+++ b/Documentation/netlink/specs/rt-link.yaml
@@ -812,10 +812,10 @@ definitions:
enum-name:
entries:
-
- name: forward
+ name: pass
value: 0
-
- name: blackhole
+ name: drop
value: 2
-
name: netkit-mode