Thread (17 messages) 17 messages, 5 authors, 2d ago

Re: [PATCH 1/3] mm: move internal mempolicy APIs to new internal header

From: Brendan Jackman <hidden>
Date: 2026-07-22 15:16:07
Also in: linux-fsdevel, linux-iommu, linux-mm, linux-nfs, lkml, loongarch

On Mon Jul 20, 2026 at 6:34 PM UTC, Vlastimil Babka (SUSE) wrote:
On 7/20/26 19:52, Matthew Wilcox wrote:
quoted
On Thu, Jul 16, 2026 at 04:57:37PM +0000, Brendan Jackman wrote:
quoted
On Thu Jul 16, 2026 at 4:48 PM UTC, Matthew Wilcox wrote:
quoted
On Thu, Jul 16, 2026 at 02:30:10PM +0000, Brendan Jackman wrote:
quoted
There are no external users for this surface, reduce the scope.
-struct folio *folio_alloc_mpol_noprof(gfp_t gfp, unsigned int order,
-		struct mempolicy *mpol, pgoff_t ilx, int nid);
Hm.  So what we're saying is that allocations which respect mempolicy are
only for core mm and not for, eg, device drivers to do.  Is that really
what we want to say?  I don't think so, because that's inconsistent
with having just widened __filemap_get_folio_mpol to allow guest_memfd
to specify a mempolicy.
guest_memfd is practically mm internal though, IMHO.
quoted
quoted
Yeah I agree, mempolicy definitely seems like a "public concept".  All
I'm saying here is this specific function doesn't have any external
users so it doesn't need to be an external header. 
I don't think that should be the metric for moving things to internal.h.
To me, internal.h is a signifier that these interfaces should only be
used by the MM.  Not that "all current users are within the MM".
Perhaps. It can be also useful to move them outside only when someone asks.
Yeah I can see this both ways. It makes sense to only expose functions
to the scope that currently needs them, but I think Matthew's right that
moving it to internal.h does kinda signal "this is private, don't touch
this" which isn't intended.
quoted
quoted
... With the ulterior motive that I want to add a new parameter to it
that actually _is_ mm-internal. Namely, alloc_flags, so I can add
ALLOC_UNMAPPED to implement AS_NO_DIRECT_MAP, i.e. the next iteration of
[0]. So basically this is
about trying to extend the allocator without creating a GFP flag.
Yeah.  I'm not sold on the whole alloc_flags thing, but I'm too busy to
sit down and think it through properly to get involved in a proper
argument about how it should work.
Well it's basically a workaround for limited gfp flags space. So we can
extend it without making that a cost for everybody, as long as those that
need the new functionality are limited.
quoted
My entirely unresearched and ill-considered opinion is that the __GFP
flags should _be_ the ALLOC flags.  We shoudn't be translating GFP flags
into ALLOC flags that are what the allocator actually uses, the
It uses both.
quoted
translation should be done at compile time.  So if GFP_KERNEL and
That would assume the gfp flags are also known at compile time, which is not
always the case.
quoted
GFP_ATOMIC need to be composed of different flags with different
The flags we are adding/considering to add are not about GFP_KERNEL vs
GFP_ATOMIC context, however.
quoted
semantics, then we should do that, not invent a different set of flags
that special people can use for special purposes.
Yep it's ugly and pragmatic, as usual. At least it's not immortalized as an
UAPI, so we can deal with exploring in a wrong direction and fixing it later.
FWIW I suspect the "proper" design requirements are something like:

1. We want some flags that we can happily squeeze into places like
   struct xa_node, and other flags that we can add bits to relatively
   freely.

2. We want some flags that are "public" and some that are "private",
   although this is intentionally vaguely defined.

The current ALLOC_/GFP_ flags split is something that kinda inelegantly
attempts to solve both at once even though they are actually probably
orthogonal requirements. Do we care about this inelegance? I think it's
pretty harmless.

Another thing that's pretty inelegant about it is that both sets of
flags percolate into the allocator at once. This is quite
confusing/tiresome when you are reading page_alloc.c (I tried to
ameliorate that with [0]) but I don't think it has much of an
architectural impact?

[0]: https://lore.kernel.org/all/20260703-alloc-trylock-v5-2-c87b714e19d3@google.com/ (local)

In the back of my mind I suspect the "neat and tidy" solution would be
something like: a single flags namespace that is split into two separate
enums, one "public" and one "private", and then a separate mechanism to
"compress" these flags into a small number of bits. But yeah I'm just
not sure working on that nice elegant cleanup would really unlock
anything of practical value. Boring little cleanups like "split out this
API from internal.h into its own header" seem like more useful ways to
spend refactoring energy in this space.

Quite likely I'm missing potential unlocks though. E.g. maybe there's
some place we currently put a gfp_t that could benefit from a "separate
compression mechanism" that could usefully shrink it to 8 bits or
whatever.
quoted
quoted
So I'm envisaging if an external user arises for it later, we'd slap two
underscores on the beginning of the internal one, (with the alloc_flags
arg), and then bring back the public one as a wrapper.

Does that make sense?
We have a long history of people just moving stuff around in patches
without knowing what the intent was if it should be moved.
I guess this patch is not critical to the rest, if that's an issue.
Well, for ALLOC_UNMAPPED we really do need an alloc_flags arg for this
function, but we can always just go straight to what I described above.
I.e. I can create the __ variant + wrapper from the start. It's just a
question of whether we prefer:

- "Yuck, there's a public wrapper here that we don't actually need", or

- "We hid this mempolicy API and people might think we'd NACK a patch to
  un-hide it".0

  https://lore.kernel.org/all/20260703-alloc-trylock-v5-2-c87b714e19d3@google.com/ (local)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help