Thread (20 messages) 20 messages, 5 authors, 5d ago

Re: [PATCH v8 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`

From: Andreas Hindborg <a.hindborg@kernel.org>
Date: 2026-07-15 06:47:52
Also in: dri-devel, driver-core, linux-block, linux-kselftest, linux-modules, linux-pci, lkml, nova-gpu, rust-for-linux

Alvin Sun [off-list ref] writes:
Replace the `THIS_MODULE` static reference in the `configfs_attrs!`
macro with `this_module::<LocalModule>()`, and update
rnull to import `LocalModule` instead of `THIS_MODULE`, consistent
with the move of `THIS_MODULE` into the `ModuleMetadata` trait.

Assisted-by: opencode:glm-5.2
Reviewed-by: Andreas Hindborg <a.hindborg@kernel.org>
Acked-by: Danilo Krummrich <dakr@kernel.org>
Signed-off-by: Alvin Sun <redacted>

Acked-by: Andreas Hindborg <a.hindborg@kernel.org>

Best regards,
Andreas Hindborg

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help