Thread (20 messages) 20 messages, 5 authors, 8h ago

Re: [PATCH v8 08/10] rust: binder: use `LocalModule` for `THIS_MODULE`

From: Alvin Sun <hidden>
Date: 2026-07-13 08:54:01
Also in: dri-devel, driver-core, linux-block, linux-kselftest, linux-modules, linux-pci, lkml, nova-gpu, rust-for-linux

On 7/13/26 16:13, Alice Ryhl wrote:
On Mon, Jul 13, 2026 at 02:45:29PM +0800, Alvin Sun wrote:
quoted
Replace the `THIS_MODULE` static reference in the binder fops with
`this_module::<LocalModule>()`, consistent with the move of
`THIS_MODULE` into the `ModuleMetadata` trait.

Assisted-by: opencode:glm-5.2
Reviewed-by: Gary Guo <gary@garyguo.net>
Acked-by: Danilo Krummrich <dakr@kernel.org>
Signed-off-by: Alvin Sun <redacted>
Most other Rust Binder commits use 'rust_binder:' prefix rather than
'rust: binder:'.
I missed this prefix convention — thanks for catching it.

I'll fix it in the next revision, along with any other feedback that 
comes in.

Best regards,
Alvin
Alice
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help