Re: [PATCH v8 10/14] media: qcom: Pass proper PAS ID to set_remote_state API
From: Sumit Garg <sumit.garg@kernel.org>
Date: 2026-07-01 12:19:52
Also in:
ath12k, dri-devel, linux-arm-msm, linux-media, linux-remoteproc, linux-wireless, lkml
On Wed, Jul 01, 2026 at 01:01:52PM +0200, Konrad Dybcio wrote:
On 7/1/26 9:44 AM, Sumit Garg wrote:quoted
On Tue, Jun 30, 2026 at 02:42:25PM +0200, Konrad Dybcio wrote:quoted
On 6/26/26 3:34 PM, Sumit Garg wrote:quoted
From: Sumit Garg <redacted> As per testing the SCM backend just ignores it while OP-TEE makes use of it to for proper book keeping purpose. Reviewed-by: Mukesh Ojha <redacted> Tested-by: Mukesh Ojha <redacted> # Lemans Reviewed-by: Vikash Garodia <vikash.garodia@oss.qualcomm.com> Signed-off-by: Sumit Garg <redacted> --- drivers/media/platform/qcom/iris/iris_firmware.c | 2 +- drivers/media/platform/qcom/venus/firmware.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)diff --git a/drivers/media/platform/qcom/iris/iris_firmware.c b/drivers/media/platform/qcom/iris/iris_firmware.c index ea9654dd679e..d2e7ba4f37e3 100644 --- a/drivers/media/platform/qcom/iris/iris_firmware.c +++ b/drivers/media/platform/qcom/iris/iris_firmware.c@@ -110,5 +110,5 @@ int iris_fw_unload(struct iris_core *core) int iris_set_hw_state(struct iris_core *core, bool resume) { - return qcom_pas_set_remote_state(resume, 0); + return qcom_pas_set_remote_state(resume, IRIS_PAS_ID); }diff --git a/drivers/media/platform/qcom/venus/firmware.c b/drivers/media/platform/qcom/venus/firmware.c index 3a38ff985822..3c0727ea137d 100644 --- a/drivers/media/platform/qcom/venus/firmware.c +++ b/drivers/media/platform/qcom/venus/firmware.c@@ -59,7 +59,7 @@ int venus_set_hw_state(struct venus_core *core, bool resume) int ret; if (core->use_tz) { - ret = qcom_pas_set_remote_state(resume, 0); + ret = qcom_pas_set_remote_state(resume, VENUS_PAS_ID);This should not be in the middle of a mildly related series.. The PAS IDs should be centralized into a single header. And the name of the driver shouldn't be part of the define. I would guesstimate that on the secure side it's probably called VPU or VIDEOI agree with your comments, this is something I would also like to consolidate on OP-TEE side as well: see discussion here [1]. However, the patch itself was needed to do book keeping on OP-TEE side but I can drop it since anyhow the video isn't functional yet in upstream dependent on the proper IOMMU support.For this patch.. I think QCTZ may be ignoring the argument so it may not matter.. on a second thought you already have it reviewed and it's already a cross-subsys merge so might as well pull it in, worst case scenario it'll revert cleanly
Thanks, I will keep it then.
Once this lands, please move all PAS defines to.. hmm.. qcom_pas.h sounds like a good candidate?
Sure, I will propose that as a follow-up change. We have to agree on common naming there. -Sumit