Re: the confusing 10000base_CR. Shouldn't it be 10000_SFI_DA?
From: Andrew Lunn <andrew@lunn.ch>
Date: 2026-06-29 13:11:14
From: Andrew Lunn <andrew@lunn.ch>
Date: 2026-06-29 13:11:14
Will wait for @Michal Kubecek's response about the manual page update and as second possibility: options to update ethtool help string. IMHO, yes the comment in ethtool.h enum definition is good as it helps developers who use ethtool.h directly but from ethtool app USER point-of-view, the manual page is the first impression and ethtool --help is second. The effort here is to help the user with a clarification, to avoid the clear confusion with the wrong naming of 10000baseCR
Is there confusion? git blame suggests it has been there 10 years, and this is the first time somebody has questioned it. I would limit changes to Documentation, man pages, help etc. Andrew