Re: the confusing 10000base_CR. Shouldn't it be 10000_SFI_DA?
From: Maxime Chevallier <maxime.chevallier@bootlin.com>
Date: 2026-06-26 14:33:59
Hi, On 6/26/26 16:15, D H, Siddaraju wrote:
Hi Linux Ethernet Team,
We explored Ethtool's "10000base_CR" PMD PHY type
and we think it might be just a wrong name.
Why we called 10000Base_CR, a confusing name?
Because it fails all below 4 major highlights of a "typical base-CR"
1. Every other Base-CR is an IEEE defined PMD specs
2. All Base-CR have AN LT (Auto-Negotiation & Link Training)
3. Almost all CR have FEC mandatory
4. IEEE CR is a very close sibling of IEEE KR, the complex ones
There is NO IEEE 802.3 or ANY other standard spec to
support 10000base-CR and the industry fully adopted
SFF-8431 Appendix-E Direct Attach cable as 10G-SFI-DA.
We feel 10000Base_CR must be renamed to 10000_SFI_DA.
SFI: SFP+ high speed serial electrical interface
DA: Direct Attach cable mediaWell it's too late for a rename, this is part of the userspace API so this name is here to stay : https://elixir.bootlin.com/linux/v7.1.1/source/include/uapi/linux/ethtool.h#L2013 This was introduced in 2016, I think we won't gain much by adding another linkmode that's equivalent. Even if this isn't strictly speaking the correct mode, even some vendors sell their DA cable as 10GBaseCR cables now :/ Maxime