Thread (19 messages) 19 messages, 6 authors, 1d ago

Re: [PATCH 3/7] cpufreq: rcpufreq_dt: use vertical import style

From: Zhongqiu Han <hidden>
Date: 2026-06-29 12:43:40
Also in: dri-devel, driver-core, linux-block, linux-pm, linux-pwm, linux-riscv, lkml, nova-gpu, rust-for-linux

On 6/29/2026 11:38 AM, Guru Das Srinagesh wrote:
Convert `use` imports to vertical layout for better readability and
maintainability.

Signed-off-by: Guru Das Srinagesh <redacted>
---
  drivers/cpufreq/rcpufreq_dt.rs | 5 ++++-
  1 file changed, 4 insertions(+), 1 deletion(-)
Hi Guru Das,
quoted hunk ↗ jump to hunk
diff --git a/drivers/cpufreq/rcpufreq_dt.rs b/drivers/cpufreq/rcpufreq_dt.rs
index 10106fa13095..6f83cf8955a6 100644
--- a/drivers/cpufreq/rcpufreq_dt.rs
+++ b/drivers/cpufreq/rcpufreq_dt.rs
@@ -6,7 +6,10 @@
      clk::Clk,
      cpu, cpufreq,
The change seems reasonable according to the Rust coding guidelines:

https://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git/tree/Documentation/rust/coding-guidelines.rst#n44

     "each item goes into its own line, and braces are used as soon as
      there is more than one item in a list."

If the preferred style is to place each imported item on its own line,
shouldn't imports such as

     cpu, cpufreq,

be formatted similarly as well? Have you run: "make LLVM=1 rustfmtcheck" 
on this change?
      cpumask::CpumaskVar,
-    device::{Core, Device},
+    device::{
+        Core,
+        Device, //
+    },
      error::code::*,
      macros::vtable,
      module_platform_driver, of, opp, platform,
Likewise?

-- 
Thx and BRs,
Zhongqiu Han
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help