Hi Jakub,
On 6/27/26 02:33, Jakub Kicinski wrote:
On Fri, 26 Jun 2026 14:39:57 +0200 Andrew Lunn wrote:
quoted
On Fri, Jun 26, 2026 at 10:33:50AM +0200, Maxime Chevallier wrote:
quoted
quoted
Sphinx follows pythons object orientate structure. So you could have a
class test_ethtool_pause_advertising, with class documentation. And
then methods within the class which are individual tests. The
commented out section would then be method documentation.
Good point, so maybe something along these lines :
- A class for the test
- methods for indivitual tests
- For readability, I've written what the internal test helper would look
like (_adv_test), and how a test would look like without the helper in
adv_rx_on_tx_on().
I'm already diving into coding, but it helps me a bit in the definition of the
"description" format :)
this is what the class would look like :
I like this :-)
This is very far from what existing python tests do in netdev.
We can probably drop the class, as it is with this discussion, it's merely a way
to regroup doc common to similar tests. The rest really is the usual set of
ksft funcs you can feed to the run function, with a set of ksft_ethtool_*
annotators for generic checks.
I would prefer to stick to the "bash on steroids" use of Python.
Maxime