Re: [PATCH net-next] net: usb: sr9700: use ETH_ALEN instead of magic number
From: Andrew Lunn <andrew@lunn.ch>
Date: 2026-01-23 19:35:43
Also in:
linux-usb
From: Andrew Lunn <andrew@lunn.ch>
Date: 2026-01-23 19:35:43
Also in:
linux-usb
On Thu, Jan 22, 2026 at 11:06:39PM -0800, Ethan Nelson-Moore wrote:
The driver hardcodes the number 6 as the number of bytes to write to the SR_PAR register, which stores the MAC address. Use ETH_ALEN instead to make the code clearer. Signed-off-by: Ethan Nelson-Moore <redacted>
Reviewed-by: Andrew Lunn <andrew@lunn.ch>
Andrew