On Tue, Sep 02, 2025 at 06:49:26PM -0400, Willem de Bruijn wrote:
Breno Leitao wrote:
quoted
Shift the definition of netpoll_cleanup() from netpoll core to the
netconsole driver, updating all relevant file references. This change
centralizes cleanup logic alongside netconsole target management,
Given netpoll_cleanup() is only called by netconsole, keep it there.
Signed-off-by: Breno Leitao <leitao@debian.org>
What's the rationale for making this a separate patch, as the
previous patch also moves the other netconsole specific code from
netpoll.c to netconsole.c?
I just tried to isolate the changes in small patches as possible.
previous functions needed to go all together, given it was they were in
a chain.
this one netpoll_cleanup() is more independent, so, I decided to
separate it, making the patches smaller individually.
And/or consider updating prefix from netpoll_.. to netconsole_..
Good point, and I agree with the feedback.
In cases like this, should I rename the function while moving, or,
adding an additional patch to rename them?
Thanks for the review,
--breno