Re: [PATCH v4 5/5] net: rnpgbe: Add register_netdev
From: Yibo Dong <dong100@mucse.com>
Date: 2025-08-15 02:29:34
Also in:
linux-doc, lkml
On Thu, Aug 14, 2025 at 05:44:51PM +0530, MD Danish Anwar wrote:
On 14/08/25 1:08 pm, Dong Yibo wrote:quoted
Initialize get mac from hw, register the netdev. Signed-off-by: Dong Yibo <dong100@mucse.com> --- drivers/net/ethernet/mucse/rnpgbe/rnpgbe.h | 18 +++++ .../net/ethernet/mucse/rnpgbe/rnpgbe_chip.c | 73 ++++++++++++++++++ drivers/net/ethernet/mucse/rnpgbe/rnpgbe_hw.h | 1 + .../net/ethernet/mucse/rnpgbe/rnpgbe_main.c | 75 +++++++++++++++++++ 4 files changed, 167 insertions(+)diff --git a/drivers/net/ethernet/mucse/rnpgbe/rnpgbe.h b/drivers/net/ethernet/mucse/rnpgbe/rnpgbe.h index 7ab1cbb432f6..7e51a8871b71 100644 --- a/drivers/net/ethernet/mucse/rnpgbe/rnpgbe.h +++ b/drivers/net/ethernet/mucse/rnpgbe/rnpgbe.h@@ -6,6 +6,7 @@ #include <linux/types.h> #include <linux/mutex.h> +#include <linux/netdevice.h> extern const struct rnpgbe_info rnpgbe_n500_info; extern const struct rnpgbe_info rnpgbe_n210_info;@@ -82,6 +83,15 @@ struct mucse_mbx_info { u32 fw2pf_mbox_vec; }; +struct mucse_hw_operations { + int (*reset_hw)(struct mucse_hw *hw); + void (*driver_status)(struct mucse_hw *hw, bool enable, int mode); +}; + +enum { + mucse_driver_insmod, +}; + struct mucse_hw { u8 pfvfnum; void __iomem *hw_addr;@@ -91,12 +101,17 @@ struct mucse_hw { u32 axi_mhz; u32 bd_uid; enum rnpgbe_hw_type hw_type; + const struct mucse_hw_operations *ops; struct mucse_dma_info dma; struct mucse_eth_info eth; struct mucse_mac_info mac; struct mucse_mbx_info mbx; + u32 flags; +#define M_FLAGS_INIT_MAC_ADDRESS BIT(0) u32 driver_version; u16 usecstocount; + int lane; + u8 perm_addr[ETH_ALEN]; }; struct mucse {@@ -117,4 +132,7 @@ struct rnpgbe_info { #define PCI_DEVICE_ID_N500_DUAL_PORT 0x8318 #define PCI_DEVICE_ID_N210 0x8208 #define PCI_DEVICE_ID_N210L 0x820a + +#define dma_wr32(dma, reg, val) writel((val), (dma)->dma_base_addr + (reg)) +#define dma_rd32(dma, reg) readl((dma)->dma_base_addr + (reg))These macros could collide with other definitions. Consider prefixing them with the driver name (rnpgbe_dma_wr32). I don't see these macros getting used anywhere in this series. They should be introduced when they are used.
dma_wr32 is used in rnpgbe_reset_hw_ops (rnpgbe_chip.c). I rename it to rnpgbe_dma_wr32. dma_rd32 is not used, I will remove it.