quoted
quoted
+static void rnpgbe_init_n500(struct mucse_hw *hw)
+{
+ struct mucse_mbx_info *mbx = &hw->mbx;
+
+ rnpgbe_init_common(hw);
+
+ mbx->fw2pf_mbox_vec = 0x28b00;
+ mbx->fw_pf_shm_base = 0x2d000;
+ mbx->pf2fw_mbox_ctrl = 0x2e000;
+ mbx->fw_pf_mbox_mask = 0x2e200;
+ hw->ring_msix_base = hw->hw_addr + 0x28700;
+ hw->usecstocount = 125;
+}
These hardcoded values should be defined in rnpgbe_hw.h as macros rather
than using magic numbers.
Got it, I will update this.
You might also want to talk to your hardware engineers and tell them
not to make silly changes like this between hardware versions. It just
makes the software harder for no reason.
Andrew