[PATCH net-next v4 0/4] netconsole: reuse netpoll_parse_ip_addr in configfs helpers
From: Breno Leitao <leitao@debian.org>
Date: 2025-08-11 18:13:39
Also in:
lkml
This patchset refactors the IP address parsing logic in the netconsole driver to eliminate code duplication and improve maintainability. The changes centralize IPv4 and IPv6 address parsing into a single function (netpoll_parse_ip_addr). For that, it needs to teach netpoll_parse_ip_addr() to handle strings with newlines, which is the type of string coming from configfs. Background The netconsole driver currently has duplicate IP address parsing logic in both local_ip_store() and remote_ip_store() functions. This duplication increases the risk of inconsistencies and makes the code harder to maintain. Benefits * Reduced code duplication: ~40 lines of duplicate parsing logic eliminated * Improved robustness: Centralized parsing reduces the chance of inconsistencies * Easier to maintain: Code follow more the netdev way --- Changes in v4: - Check the `end` string returned by netpoll_parse_ip_addr(), and fail if it is different than 0 and \n. (Jakub) * Also removed Simon reviewed-by given I changed the code slightly. - Link to v3: https://lore.kernel.org/r/20250723-netconsole_ref-v3-0-8be9b24e4a99@debian.org (local) Changes in v3: - Avoid #ifdef and use if (IS_ENABLED()) instead (Simon) - Assing an int to a boolean using !! (Simon) - Link to v2: https://lore.kernel.org/r/20250721-netconsole_ref-v2-0-b42f1833565a@debian.org (local) Changes in v2: - Moved the netpoll_parse_ip_addr() to outside the dynamic block (Jakub) - Link to v1: https://lore.kernel.org/r/20250718-netconsole_ref-v1-0-86ef253b7a7a@debian.org (local) --- Breno Leitao (4): netconsole: move netpoll_parse_ip_addr() earlier for reuse netconsole: add support for strings with new line in netpoll_parse_ip_addr netconsole: use netpoll_parse_ip_addr in local_ip_store netconsole: use netpoll_parse_ip_addr in local_ip_store drivers/net/netconsole.c | 91 ++++++++++++++++++++---------------------------- 1 file changed, 37 insertions(+), 54 deletions(-) --- base-commit: 37816488247ddddbc3de113c78c83572274b1e2e change-id: 20250718-netconsole_ref-c1f7254cfb51 Best regards, -- Breno Leitao [off-list ref]