[PATCH net-next v2 0/5] netconsole: reuse netpoll_parse_ip_addr in configfs helpers
flat view
STALE441d
From: Breno Leitao <leitao@debian.org>
Date: 2025-07-21 13:02:12
Also in:
lkml
This patchset refactors the IP address parsing logic in the netconsole driver to eliminate code duplication and improve maintainability. The changes centralize IPv4 and IPv6 address parsing into a single function (netpoll_parse_ip_addr). For that, it needs to teach netpoll_parse_ip_addr() to handle strings with newlines, which is the type of string coming from configfs. Background The netconsole driver currently has duplicate IP address parsing logic in both local_ip_store() and remote_ip_store() functions. This duplication increases the risk of inconsistencies and makes the code harder to maintain. Benefits * Reduced code duplication: ~40 lines of duplicate parsing logic eliminated * Improved robustness: Centralized parsing reduces the chance of inconsistencies * Easier to maintain: Code follow more the netdev way PS: The patches are very well contained in other to help review. --- Changes in v2: - Moved the netpoll_parse_ip_addr() to outside the dynamic block (Jakub) - Link to v1: https://lore.kernel.org/r/20250718-netconsole_ref-v1-0-86ef253b7a7a@debian.org (local) --- Breno Leitao (5): netpoll: Remove unused fields from inet_addr union netconsole: move netpoll_parse_ip_addr() earlier for reuse netconsole: add support for strings with new line in netpoll_parse_ip_addr netconsole: use netpoll_parse_ip_addr in local_ip_store netconsole: use netpoll_parse_ip_addr in local_ip_store drivers/net/netconsole.c | 85 ++++++++++++++++++------------------------------ include/linux/netpoll.h | 3 -- 2 files changed, 31 insertions(+), 57 deletions(-) --- base-commit: d61f6cb6f6ef3c70d2ccc0d9c85c508cb8017da9 change-id: 20250718-netconsole_ref-c1f7254cfb51 Best regards, -- Breno Leitao [off-list ref]