Thread (46 messages) 46 messages, 11 authors, 2025-06-16

Re: [PATCH 01/20] bitfield: introduce HWORD_UPDATE bitfield macros

From: Jakub Kicinski <kuba@kernel.org>
Date: 2025-06-13 14:59:18
Also in: dri-devel, linux-clk, linux-media, linux-mmc, linux-pci, linux-phy, linux-pm, linux-rockchip, linux-sound, lkml, llvm

On Fri, 13 Jun 2025 08:28:40 -0400 Yury Norov wrote:
quoted
quoted
And perhaps that (and more potential users) could persuade Jakub that
this is not that weird after all?  
I will operate under the assumption that Jakub's opinion will not change
as he ignored the commit message that talks about multiple vendors,
ignored the cover letter that talks about multiple vendors, and ignored
my e-mail where I once again made it clear to him that it's multiple
vendors, and still claims it's a Rockchip specific convention.  
As far as I understood, he concerns not about number of drivers that
opencode HIWORD_UPDATE(), but that this macro is not generic enough
to live in bitfield.h. And it's a valid concern - I doubt it will
be helpful somewhere in core and arch files.
Exactly.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help