On 6/23/25 12:33, Fabian Pfitzner wrote:
Put mcast querier dumping code into a shared function. This function
will be called from the bridge utility in a later patch.
Adapt the code such that the vtb parameter is used
instead of tb[IFLA_BR_MCAST_QUERIER_STATE].
Signed-off-by: Fabian Pfitzner <redacted>
---
I decided to not only move the code into a separate function, but also
to adapt it to fit into the function. If I split it into a pure refactoring
and an adapting commit, the former will not compile preventing git bisects.
---
include/bridge.h | 3 +++
ip/iplink_bridge.c | 59 +++-----------------------------------------
lib/bridge.c | 61 ++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 67 insertions(+), 56 deletions(-)
Acked-by: Nikolay Aleksandrov <razor@blackwall.org>