On Sat, May 17, 2025 at 12:58:35PM +0300, Sagi Grimberg wrote:
quoted
#include "nvme.h"
#include "fabrics.h"
@@ -166,12 +166,12 @@ struct nvme_tcp_queue {
bool rd_enabled;
bool hdr_digest;
bool data_digest;
bool tls_enabled;
- struct ahash_request *rcv_hash;
- struct ahash_request *snd_hash;
+ u32 rcv_crc;
+ u32 snd_crc;
__le32 exp_ddgst;
__le32 recv_ddgst;
Let's call it rcv_dgst (recv digest) and snd_dgst (send digest).
Other than that, looks good to me.
Reviewed-by: Sagi Grimberg <sagi@grimberg.me>
rcv_dgst would be awfully close to recv_ddgst which holds the on-wire digest
that is received. I think I slightly prefer *_crc, since that helps
differentiate the in-progress values from the finalized values.
- Eric