Thread (26 messages) 26 messages, 2 authors, 2025-03-27

Re: [Intel-wired-lan] [PATCH iwl-next v10 05/14] igc: rename I225_RXPBSIZE_DEFAULT and I225_TXPBSIZE_DEFAULT

From: Mor Bar-Gabay <hidden>
Date: 2025-03-27 12:57:12
Also in: bpf, intel-wired-lan, linux-arm-kernel, lkml

On 18/03/2025 5:07, Faizal Rahim wrote:
Rename RX and TX packet buffer size macros in preparation for an
upcoming patch that will refactor buffer size handling using FIELD_PREP
and GENMASK.

Changes:
- Rename I225_RXPBSIZE_DEFAULT to IGC_RXPBSIZE_EXP_BMC_DEFAULT.
   The EXP_BMC suffix explicitly indicates Express and BMC buffer
   default values, improving readability and reusability for the
   upcoming changes, while also better reflecting the current buffer
   allocations.
- Rename I225_TXPBSIZE_DEFAULT to IGC_TXPBSIZE_DEFAULT.

These registers apply to both i225 and i226, so using the IGC prefix
aligns with existing macro naming conventions.

Signed-off-by: Faizal Rahim <redacted>
---
  drivers/net/ethernet/intel/igc/igc_defines.h | 7 ++++---
  drivers/net/ethernet/intel/igc/igc_main.c    | 4 ++--
  drivers/net/ethernet/intel/igc/igc_tsn.c     | 2 +-
  3 files changed, 7 insertions(+), 6 deletions(-)
Tested-by: Mor Bar-Gabay <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help