Thread (11 messages) flat view 11 messages, 4 authors, 2025-02-21

Re: [PATCH net-next v3 2/2] net: plumb extack in __dev_change_net_namespace()

From: Kuniyuki Iwashima <hidden>
Date: 2025-02-21 04:34:26

From: Nicolas Dichtel <redacted>
Date: Thu, 20 Feb 2025 16:11:43 +0100
Le 20/02/2025 à 14:24, Eric Dumazet a écrit :
quoted
On Thu, Feb 20, 2025 at 2:22 PM Nicolas Dichtel
[off-list ref] wrote:
quoted
Le 20/02/2025 à 14:17, Eric Dumazet a écrit :
quoted
On Thu, Feb 20, 2025 at 2:03 PM Nicolas Dichtel
[off-list ref] wrote:
quoted
It could be hard to understand why the netlink command fails. For example,
if dev->netns_local is set, the error is "Invalid argument".
After your patch, a new message is : "  "The interface has the 'netns
local' property""

Honestly, I am not sure we export to user space the concept of 'netns local'

"This interface netns is not allowed to be changed" or something like that ?
Frankly, I was hesitating. I used 'netns local' to ease the link with the new
netlink attribute, and with what was displayed by ethtool for a long time.
I don't have a strong opinion about this.
No strong opinion either, I always have been confused by NETNS_LOCAL choice.
Yes, it's not obvious. Maybe it could be renamed before exposing it to userspace
via netlink.
What about 'netns-locked'? Does someone have a better proposal?
Maybe NETNS_IMMUTABLE and netns-immutable ?
Then we can say "The interface netns is immutable" in extack.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help