Thread (15 messages) 15 messages, 7 authors, 2024-10-09

Re: [PATCH 00/51] treewide: Switch to __pm_runtime_put_autosuspend()

From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Date: 2024-10-07 22:25:10
Also in: amd-gfx, asahi, dmaengine, dri-devel, imx, linux-arm-kernel, linux-bluetooth, linux-clk, linux-crypto, linux-gpio, linux-i2c, linux-i3c, linux-iio, linux-input, linux-iommu, linux-media, linux-mediatek, linux-mmc, linux-pci, linux-phy, linux-pwm, linux-remoteproc, linux-serial, linux-sound, linux-spi, linux-staging, linux-usb, linux-wireless, lkml, nouveau

Hi Ulf,

On Tue, Oct 08, 2024 at 12:08:24AM +0200, Ulf Hansson wrote:
On Mon, 7 Oct 2024 at 20:49, Laurent Pinchart wrote:
quoted
On Fri, Oct 04, 2024 at 04:38:36PM +0200, Ulf Hansson wrote:
quoted
On Fri, 4 Oct 2024 at 11:41, Sakari Ailus wrote:
quoted
Hello everyone,

This set will switch the users of pm_runtime_put_autosuspend() to
__pm_runtime_put_autosuspend() while the former will soon be re-purposed
to include a call to pm_runtime_mark_last_busy(). The two are almost
always used together, apart from bugs which are likely common. Going
forward, most new users should be using pm_runtime_put_autosuspend().

Once this conversion is done and pm_runtime_put_autosuspend() re-purposed,
I'll post another set to merge the calls to __pm_runtime_put_autosuspend()
and pm_runtime_mark_last_busy().
That sounds like it could cause a lot of churns.

Why not add a new helper function that does the
pm_runtime_put_autosuspend() and the pm_runtime_mark_last_busy()
things? Then we can start moving users over to this new interface,
rather than having this intermediate step?
I think the API would be nicer if we used the shortest and simplest
function names for the most common use cases. Following
pm_runtime_put_autosuspend() with pm_runtime_mark_last_busy() is that
most common use case. That's why I like Sakari's approach of repurposing
pm_runtime_put_autosuspend(), and introducing
__pm_runtime_put_autosuspend() for the odd cases where
pm_runtime_mark_last_busy() shouldn't be called.
Okay, so the reason for this approach is because we couldn't find a
short and descriptive name that could be used in favor of
pm_runtime_put_autosuspend(). Let me throw some ideas at it and maybe
you like it - or not. :-)
I like the idea at least :-)
I don't know what options you guys discussed, but to me the entire
"autosuspend"-suffix isn't really that necessary in my opinion. There
are more ways than calling pm_runtime_put_autosuspend() that triggers
us to use the RPM_AUTO flag for rpm_suspend(). For example, just
calling pm_runtime_put() has the similar effect.
To be honest, I'm lost there. pm_runtime_put() calls
__pm_runtime_idle(RPM_GET_PUT | RPM_ASYNC), while
pm_runtime_put_autosuspend() calls __pm_runtime_suspend(RPM_GET_PUT |
RPM_ASYNC | RPM_AUTO).
Moreover, it's similar for pm_runtime_mark_last_busy(), it's called
during rpm_resume() too, for example. So why bother about having
"mark_last_busy" in the new name too.

That said, my suggestion is simply "pm_runtime_put_suspend".
Can we do even better, and make pm_runtime_put() to handle autosuspend
automatically when autosuspend is enabled ?
If you don't like it, I will certainly not object to your current
approach, even if I think it leads to unnecessary churns.

[...]

Kind regards
Uffe
-- 
Regards,

Laurent Pinchart
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help