Re: [PATCH net-next v3 03/10] net: pcs: xpcs: Convert xpcs_id to dw_xpcs_desc
From: Andrew Lunn <andrew@lunn.ch>
Date: 2024-06-27 13:10:39
Also in:
linux-devicetree, lkml, openbmc
From: Andrew Lunn <andrew@lunn.ch>
Date: 2024-06-27 13:10:39
Also in:
linux-devicetree, lkml, openbmc
- for (i = 0; i < ARRAY_SIZE(xpcs_id_list); i++) {
- const struct xpcs_id *entry = &xpcs_id_list[i];
+ for (i = 0; i < ARRAY_SIZE(xpcs_desc_list); i++) {
+ const struct dw_xpcs_desc *entry = &xpcs_desc_list[i];
if ((xpcs_id & entry->mask) != entry->id)
continue;
- xpcs->id = entry;
+ xpcs->desc = entry;
Maybe rename entry to desc here?
Otherwise
Reviewed-by: Andrew Lunn <andrew@lunn.ch>
Andrew