Thread (29 messages) flat view 29 messages, 2 authors, 2022-04-16

Re: [RFCv5 PATCH net-next 01/20] net: rename net_device->features to net_device->active_features

From: Jakub Kicinski <kuba@kernel.org>
Date: 2022-03-25 01:03:38

On Thu, 24 Mar 2022 17:58:32 -0700 Jakub Kicinski wrote:
On Thu, 24 Mar 2022 23:49:13 +0800 Jian Shen wrote:
quoted
The net_device->features indicates the active features of the
net device, rename it to active_features, make it esaier to
define feature helpers.  
This breaks the build.
I see you mention that the work is not complete in the cover letter.
Either way this patch seems unnecessary, you can call the helpers
for "active" features like you do, but don't start by renaming the
existing field. The patch will be enormous.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help