On 2021/12/3 19:15, Leon Romanovsky wrote:
On Fri, Dec 03, 2021 at 05:20:55PM +0800, Guangbin Huang wrote:
quoted
From: Hao Chen <redacted>
Add void before function which don't receive ret to improve code
readability.
Signed-off-by: Hao Chen <redacted>
Signed-off-by: Guangbin Huang <redacted>
---
drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_devlink.c | 2 +-
drivers/net/ethernet/hisilicon/hns3/hns3vf/hclgevf_devlink.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
NAK,
Please stop to do it and fix your static analyzer.
https://lore.kernel.org/linux-rdma/20211119172830.GL876299@ziepe.ca/ (local)
We don't add (void) in the kernel and especially for the functions that
already declared as void.
void devlink_register(struct devlink *devlink)
Thanks
Ok, I remove this patch.
Thanks