Re: [PATCH net-next 07/11] net: hns3: add void before function which don't receive ret
From: Leon Romanovsky <leon@kernel.org>
Date: 2021-12-03 11:15:44
Also in:
lkml
On Fri, Dec 03, 2021 at 05:20:55PM +0800, Guangbin Huang wrote:
From: Hao Chen <redacted> Add void before function which don't receive ret to improve code readability. Signed-off-by: Hao Chen <redacted> Signed-off-by: Guangbin Huang <redacted> --- drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_devlink.c | 2 +- drivers/net/ethernet/hisilicon/hns3/hns3vf/hclgevf_devlink.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)
NAK, Please stop to do it and fix your static analyzer. https://lore.kernel.org/linux-rdma/20211119172830.GL876299@ziepe.ca/ (local) We don't add (void) in the kernel and especially for the functions that already declared as void. void devlink_register(struct devlink *devlink) Thanks
quoted hunk ↗ jump to hunk
diff --git a/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_devlink.c b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_devlink.c index 4c441e6a5082..9c3199d3c8ee 100644 --- a/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_devlink.c +++ b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_devlink.c@@ -120,7 +120,7 @@ int hclge_devlink_init(struct hclge_dev *hdev) hdev->devlink = devlink; devlink_set_features(devlink, DEVLINK_F_RELOAD); - devlink_register(devlink); + (void)devlink_register(devlink); return 0; }diff --git a/drivers/net/ethernet/hisilicon/hns3/hns3vf/hclgevf_devlink.c b/drivers/net/ethernet/hisilicon/hns3/hns3vf/hclgevf_devlink.c index fdc19868b818..75d2926729d3 100644 --- a/drivers/net/ethernet/hisilicon/hns3/hns3vf/hclgevf_devlink.c +++ b/drivers/net/ethernet/hisilicon/hns3/hns3vf/hclgevf_devlink.c@@ -122,7 +122,7 @@ int hclgevf_devlink_init(struct hclgevf_dev *hdev) hdev->devlink = devlink; devlink_set_features(devlink, DEVLINK_F_RELOAD); - devlink_register(devlink); + (void)devlink_register(devlink); return 0; }-- 2.33.0