From: Eric Dumazet <edumazet@google.com>
sk_stream_alloc_skb() is only used by TCP.
Rename it to tcp_stream_alloc_skb() and apply small
optimizations.
Eric Dumazet (3):
tcp: rename sk_stream_alloc_skb
tcp: use MAX_TCP_HEADER in tcp_stream_alloc_skb
tcp: remove unneeded code from tcp_stream_alloc_skb()
include/net/sock.h | 3 ---
include/net/tcp.h | 2 ++
net/ipv4/tcp.c | 19 ++++++++-----------
net/ipv4/tcp_output.c | 10 +++++-----
4 files changed, 15 insertions(+), 19 deletions(-)
--
2.33.0.1079.g6e70778dc9-goog