Thread (19 messages) flat view 19 messages, 5 authors, 2021-10-25

Re: [PATCH v2 1/2] net: macb: Clean up macb_validate

From: Nicolas Ferre <nicolas.ferre@microchip.com>
Date: 2021-10-12 09:24:58

On 12/10/2021 at 10:33, Antoine Tenart wrote:
Hello Sean,

Quoting Sean Anderson (2021-10-11 18:55:16)
quoted
As the number of interfaces grows, the number of if statements grows
ever more unweildy. Clean everything up a bit by using a switch
statement. No functional change intended.
I'm not 100% convinced this makes macb_validate more readable: there are
lots of conditions, and jumps, in the switch.
I agree with Antoine that the result is not much more readable.

Regards,
   Nicolas
Maybe you could try a mixed approach; keeping the invalid modes checks
(bitmap_zero) at the beginning and once we know the mode is valid using
a switch statement. That might make it easier to read as this should
remove lots of conditionals. (We'll still have the one/_NA checks
though).

(Also having patch 1 first will improve things).

Thanks,
Antoine

-- 
Nicolas Ferre
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help