Thread (16 messages) 16 messages, 4 authors, 2021-08-11

Re: [RFC PATCH net-next 4/4] net: dsa: b53: express b53_for_each_port in terms of dsa_switch_for_each_port

flat view

From: Vladimir Oltean <olteanv@gmail.com>
Date: 2021-08-10 13:15:00

On Tue, Aug 10, 2021 at 02:39:08AM -0700, Florian Fainelli wrote:
On 8/9/2021 12:03 PM, Vladimir Oltean wrote:
quoted
Merging the two allows us to remove the open-coded
"dev->enabled_ports & BIT(i)" check from b53_br_join and b53_br_leave,
while still avoiding a quadratic iteration through the switch's ports.

Sadly I don't know if it's possible to completely get rid of
b53_for_each_port and replace it with dsa_switch_for_each_available_port,
especially for the platforms that use pdata and not OF bindings.

Signed-off-by: Vladimir Oltean <vladimir.oltean@nxp.com>
We should really be able to eliminate b53_for_each_port() entirely, let me
try to submit a patch doing that when I come back from vacation or you can
do it, and if there are bugs, I will address them.
I will let you do it when you come back, until then I believe the
existing conversion has a fairly low risk of introducing any bugs.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help