On 8/9/2021 12:03 PM, Vladimir Oltean wrote:
Merging the two allows us to remove the open-coded
"dev->enabled_ports & BIT(i)" check from b53_br_join and b53_br_leave,
while still avoiding a quadratic iteration through the switch's ports.
Sadly I don't know if it's possible to completely get rid of
b53_for_each_port and replace it with dsa_switch_for_each_available_port,
especially for the platforms that use pdata and not OF bindings.
Signed-off-by: Vladimir Oltean <vladimir.oltean@nxp.com>
We should really be able to eliminate b53_for_each_port() entirely, let
me try to submit a patch doing that when I come back from vacation or
you can do it, and if there are bugs, I will address them.
--
Florian