[PATCH net-next] net: phy: marvell: use phy_modify_changed() for marvell_set_polarity()

Subsystems: ethernet phy library, networking drivers, the rest

STALE1893d

4 messages, 4 authors, 2021-06-03 · open the first message on its own page

[PATCH net-next] net: phy: marvell: use phy_modify_changed() for marvell_set_polarity()

From: Russell King <hidden>
Date: 2021-06-03 13:01:16

Rather than open-coding the phy_modify_changed() sequence, use this
helper in marvell_set_polarity().

Signed-off-by: Russell King <redacted>
---
 drivers/net/phy/marvell.c | 27 ++++++---------------------
 1 file changed, 6 insertions(+), 21 deletions(-)
diff --git a/drivers/net/phy/marvell.c b/drivers/net/phy/marvell.c
index e6721c1c26c2..23751d95855b 100644
--- a/drivers/net/phy/marvell.c
+++ b/drivers/net/phy/marvell.c
@@ -367,39 +367,24 @@ static irqreturn_t marvell_handle_interrupt(struct phy_device *phydev)
 
 static int marvell_set_polarity(struct phy_device *phydev, int polarity)
 {
-	int reg;
-	int err;
-	int val;
-
-	/* get the current settings */
-	reg = phy_read(phydev, MII_M1011_PHY_SCR);
-	if (reg < 0)
-		return reg;
+	u16 val;
 
-	val = reg;
-	val &= ~MII_M1011_PHY_SCR_AUTO_CROSS;
 	switch (polarity) {
 	case ETH_TP_MDI:
-		val |= MII_M1011_PHY_SCR_MDI;
+		val = MII_M1011_PHY_SCR_MDI;
 		break;
 	case ETH_TP_MDI_X:
-		val |= MII_M1011_PHY_SCR_MDI_X;
+		val = MII_M1011_PHY_SCR_MDI_X;
 		break;
 	case ETH_TP_MDI_AUTO:
 	case ETH_TP_MDI_INVALID:
 	default:
-		val |= MII_M1011_PHY_SCR_AUTO_CROSS;
+		val = MII_M1011_PHY_SCR_AUTO_CROSS;
 		break;
 	}
 
-	if (val != reg) {
-		/* Set the new polarity value in the register */
-		err = phy_write(phydev, MII_M1011_PHY_SCR, val);
-		if (err)
-			return err;
-	}
-
-	return val != reg;
+	return phy_modify_changed(phydev, MII_M1011_PHY_SCR,
+				  MII_M1011_PHY_SCR_AUTO_CROSS, val);
 }
 
 static int marvell_config_aneg(struct phy_device *phydev)
-- 
2.20.1

Re: [PATCH net-next] net: phy: marvell: use phy_modify_changed() for marvell_set_polarity()

From: Andrew Lunn <andrew@lunn.ch>
Date: 2021-06-03 13:53:48

On Thu, Jun 03, 2021 at 02:01:10PM +0100, Russell King wrote:
Rather than open-coding the phy_modify_changed() sequence, use this
helper in marvell_set_polarity().

Signed-off-by: Russell King <redacted>
Reviewed-by: Andrew Lunn <andrew@lunn.ch>

    Andrew

Re: [PATCH net-next] net: phy: marvell: use phy_modify_changed() for marvell_set_polarity()

From: Marek Behún <kabel@kernel.org>
Date: 2021-06-03 15:21:20

On Thu, 03 Jun 2021 14:01:10 +0100
Russell King [off-list ref] wrote:
Rather than open-coding the phy_modify_changed() sequence, use this
helper in marvell_set_polarity().

Signed-off-by: Russell King <redacted>
Reviewed-by: Marek Behún <kabel@kernel.org>

Re: [PATCH net-next] net: phy: marvell: use phy_modify_changed() for marvell_set_polarity()

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-06-03 22:30:16

Hello:

This patch was applied to netdev/net-next.git (refs/heads/master):

On Thu, 03 Jun 2021 14:01:10 +0100 you wrote:
Rather than open-coding the phy_modify_changed() sequence, use this
helper in marvell_set_polarity().

Signed-off-by: Russell King <redacted>
---
 drivers/net/phy/marvell.c | 27 ++++++---------------------
 1 file changed, 6 insertions(+), 21 deletions(-)
Here is the summary with links:
  - [net-next] net: phy: marvell: use phy_modify_changed() for marvell_set_polarity()
    https://git.kernel.org/netdev/net-next/c/feb938fad63f

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help