pon., 22 cze 2020 o 15:25 Russell King - ARM Linux admin
[off-list ref] napisał(a):
On Mon, Jun 22, 2020 at 11:37:42AM +0200, Bartosz Golaszewski wrote:
quoted
From: Bartosz Golaszewski <redacted>
Currently many MAC drivers control the regulator supplying the PHY but
this is conceptually wrong. The regulator should be defined as a property
of the PHY node on the MDIO bus and controlled by the MDIO sub-system.
Add support for an optional PHY regulator which will be enabled before
optional deasserting of the reset signal.
I wonder if this is the right place for this - MDIO devices do not have
to be PHYs - they can be switches, and using "phy-supply" for a switch
doesn't seem logical.
However, I can see the utility of having having a supply provided for
all mdio devices, so it seems to me to be a naming issue. Andrew?
I followed the example of the phy reset retrieved in
mdiobus_register_reset(). I'm happy to change it to some other name.
Bart