Thread (6 messages) flat view 6 messages, 4 authors, 2020-06-20

Re: [PATCH] linux++, this: rename "struct notifier_block *this"

From: Jan Engelhardt <hidden>
Date: 2020-06-19 10:28:57
Also in: linux-arch, lkml, netfilter-devel

On Friday 2020-06-19 09:46, Christoph Hellwig wrote:
On Fri, Jun 19, 2020 at 12:06:45AM +0300, Alexey Dobriyan wrote:
quoted
Rename
	struct notifier_block *this
to
	struct notifier_block *nb

"nb" is arguably a better name for notifier block.
But not enough better to cause tons of pointless churn.  Feel free
to use better naming in new code you write or do significant changes
to, but stop these pointless renames.
Well, judging from the mention of "linux++" in the subject, I figure 
this is the old discussion of someone trying to make Linux code, or 
parts thereof, work in a C++ environment. Since the patch does not just 
touch headers but .c files, I deduce that there seems to be a project 
trying to build Linux, or a subset thereof, as a C++ program for the fun 
of it. UML could come to mind.

Is it a hot potato? Definitely. But so was IPv6 NAT, and now we have it 
anyway.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help