Re: [RFC net-next 1/3] net: marvell: prestera: Add Switchdev driver for Prestera family ASIC device 98DX325x (AC3x)
From: Jiri Pirko <jiri@resnulli.us>
Date: 2020-02-28 06:36:28
Also in:
lkml
From: Jiri Pirko <jiri@resnulli.us>
Date: 2020-02-28 06:36:28
Also in:
lkml
Fri, Feb 28, 2020 at 12:50:58AM CET, vadym.kochan@plvision.eu wrote:
On Thu, Feb 27, 2020 at 10:43:57PM +0100, Andrew Lunn wrote:quoted
quoted
quoted
Please be consistent. Make your prefixes, name, filenames the same. For example: prestera_driver_kind[] = "prestera"; Applied to the whole code.So you suggested to use prestera_ as a prefix, I dont see a problem with that, but why not mvsw_pr_ ? So it has the vendor, device name parts together as a key. Also it is necessary to apply prefix for the static names ?Although static names don't cause linker issues, you do still see them in opps stack traces, etc. It just helps track down where the symbols come from, if they all have a prefix. AndrewSure, thanks, makes sense. But is it necessary that prefix should match filenames too ? Would it be OK to use just 'mvpr_' instead of 'prestera_'
I would vote for "prestera_". It is clean, consistent, obvious.
for funcs & types in this particular case ? Regards, Vadym Kochan