Re: [PATCH net-next v3 4/9] sysfs: add sysfs_change_owner()
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2020-02-20 11:23:18
Also in:
linux-pm, lkml
On Tue, Feb 18, 2020 at 05:29:38PM +0100, Christian Brauner wrote:
quoted hunk ↗ jump to hunk
Add a helper to change the owner of sysfs objects. This function will be used to correctly account for kobject ownership changes, e.g. when moving network devices between network namespaces. Signed-off-by: Christian Brauner <redacted> --- /* v2 */ - Greg Kroah-Hartman [off-list ref]: - Add comment how ownership of sysfs object is changed. /* v3 */ - Greg Kroah-Hartman [off-list ref]: - Add explicit uid/gid parameters. --- fs/sysfs/file.c | 39 +++++++++++++++++++++++++++++++++++++++ include/linux/sysfs.h | 6 ++++++ 2 files changed, 45 insertions(+)diff --git a/fs/sysfs/file.c b/fs/sysfs/file.c index df5107d7b3fd..02f7e852aad4 100644 --- a/fs/sysfs/file.c +++ b/fs/sysfs/file.c@@ -665,3 +665,42 @@ int sysfs_file_change_owner(struct kobject *kobj, kuid_t kuid, kgid_t kgid) return error; } EXPORT_SYMBOL_GPL(sysfs_file_change_owner); + +/** + * sysfs_change_owner - change owner of the given object.
"and all of the files associated with this kobject", right?
+ * @kobj: object.
+ * @kuid: new owner's kuid
+ * @kgid: new owner's kgid
+ */
+int sysfs_change_owner(struct kobject *kobj, kuid_t kuid, kgid_t kgid)
+{
+ int error;
+ const struct kobj_type *ktype;
+
+ if (!kobj->state_in_sysfs)
+ return -EINVAL;
+
+ error = sysfs_file_change_owner(kobj, kuid, kgid);Ok, this changes the attributes of the sysfs directory for the kobject itself.
+ if (error)
+ return error;
+
+ ktype = get_ktype(kobj);
+ if (ktype) {
+ struct attribute **kattr;
+
+ for (kattr = ktype->default_attrs; kattr && *kattr; kattr++) {
+ error = sysfs_file_change_owner_by_name(
+ kobj, (*kattr)->name, kuid, kgid);
+ if (error)
+ return error;
+ }And here you change all of the files of the kobject. But what about files that have a subdir? Does that also happen here?
+ + error = sysfs_groups_change_owner(kobj, ktype->default_groups, + kuid, kgid);
Then what are you changing here? I think the kerneldoc needs a lot more explaination as to what is going on in this function and why you would call it, and not some of the other functions you are adding. thanks, greg k-h