On Tue, 2018-09-25 at 22:54 +0200, Jason A. Donenfeld wrote:
Hi Joe,
On Tue, Sep 25, 2018 at 10:21 PM Joe Perches [off-list ref] wrote:
quoted
I'd still prefer as all these are effectively
debugging output that you convert the pr_info
uses pr_debug and so avoid using pr_fmt altogether.
I started to write back, "sure no problem, this will be in v7," but
then I gave it a closer look, and I think actually I'll be changing
these into pr_err/pr_info and not naming this "DEBUG" but rather
"SELFTEST", since I think these are actually very good to have beyond
mere debugging.
Then you should change the CONFIG_ZINC_DEBUG option too.
Dunno what you should do with the
#ifdef DEBUG
BUG_ON(...);
#endif
uses though.