Thread (28 messages) flat view 28 messages, 5 authors, 2018-09-14

Re: [PATCH net-next 08/13] net: sched: rename tcf_block_get{_ext}() and tcf_block_put{_ext}()

From: Vlad Buslov <hidden>
Date: 2018-09-14 15:52:26

On Thu 13 Sep 2018 at 17:21, Cong Wang [off-list ref] wrote:
On Wed, Sep 12, 2018 at 1:24 AM Vlad Buslov [off-list ref] wrote:
quoted

On Fri 07 Sep 2018 at 20:09, Cong Wang [off-list ref] wrote:
quoted
On Thu, Sep 6, 2018 at 12:59 AM Vlad Buslov [off-list ref] wrote:
quoted
Functions tcf_block_get{_ext}() and tcf_block_put{_ext}() actually
attach/detach block to specific Qdisc besides just taking/putting
reference. Rename them according to their purpose.
Where exactly does it attach to?

Each qdisc provides a pointer to a pointer of a block, like
&cl->block. It is where the result is saved to. It takes a parameter
of Qdisc* merely for read-only purpose.
tcf_block_attach_ext() passes qdisc parameter to tcf_block_owner_add()
which saves qdisc to new tcf_block_owner_item and adds the item to
block's owner list. I proposed several naming options for these
functions to Jiri on internal review and he suggested "attach" as better
option.
But that is merely item->q = q, this is why I said it is read-only,
hard to claim this is attaching.

quoted
quoted
So, renaming it to *attach() is even confusing, at least not
any better. Please find other names or leave them as they are.
What would you recommend?
I don't know, perhaps "acquire"?

Or, leaving tcf_block_get() as it is but rename your refcnt
increment function to be something like tcf_block_refcnt_get()?
Cong, I'm okay with both options.

Jiri, which naming would you prefer?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help