On Fri 07 Sep 2018 at 20:09, Cong Wang [off-list ref] wrote:
On Thu, Sep 6, 2018 at 12:59 AM Vlad Buslov [off-list ref] wrote:
quoted
Functions tcf_block_get{_ext}() and tcf_block_put{_ext}() actually
attach/detach block to specific Qdisc besides just taking/putting
reference. Rename them according to their purpose.
Where exactly does it attach to?
Each qdisc provides a pointer to a pointer of a block, like
&cl->block. It is where the result is saved to. It takes a parameter
of Qdisc* merely for read-only purpose.
tcf_block_attach_ext() passes qdisc parameter to tcf_block_owner_add()
which saves qdisc to new tcf_block_owner_item and adds the item to
block's owner list. I proposed several naming options for these
functions to Jiri on internal review and he suggested "attach" as better
option.
So, renaming it to *attach() is even confusing, at least not
any better. Please find other names or leave them as they are.
What would you recommend?