[PATCH] RDS is not Radio Data System

Subsystems: networking [general], rds - reliable datagram sockets, the rest

STALE2928d

5 messages, 3 authors, 2018-08-06 · open the first message on its own page

[PATCH] RDS is not Radio Data System

From: Pavel Machek <hidden>
Date: 2018-08-05 06:59:34

Hi!

Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
easily confused with Radio Data System (which we may want to support
in kernel, too).

I wonder if option should be named NET_RDS, instead?

And this sounds like a good idea:

(Plus, we normally have "module will be called foobar" and if unsure
say X. What happened to those?)
diff --git a/net/rds/Kconfig b/net/rds/Kconfig
index 41f7556..2738f14 100644
--- a/net/rds/Kconfig
+++ b/net/rds/Kconfig
@@ -1,6 +1,6 @@
 
 config RDS
-	tristate "The RDS Protocol"
+	tristate "The Reliable Datagram Sockets (RDS) Protocol"
 	depends on INET
 	---help---
 	  The RDS (Reliable Datagram Sockets) protocol provides reliable,


-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Re: [PATCH] RDS is not Radio Data System

From: Sowmini Varadhan <hidden>
Date: 2018-08-05 10:19:57

On (08/05/18 08:59), Pavel Machek wrote:
Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
easily confused with Radio Data System (which we may want to support
in kernel, too).

I wonder if option should be named NET_RDS, instead?
RDS has been around for a while now (since 2.6). How will you
rename proposal manage backward compatibility? Why can't you call
your new option CONFIG_RADIO  or similar instead?

Are we going to rename NFS* to NET_NFS* because someone decided
to reuse the NFS acronym? 
And this sounds like a good idea:
-	tristate "The RDS Protocol"
+	tristate "The Reliable Datagram Sockets (RDS) Protocol"
surn that sounds fine.

--Sowmini

Re: [PATCH] RDS is not Radio Data System

From: Pavel Machek <hidden>
Date: 2018-08-05 10:38:01

On Sun 2018-08-05 06:19:45, Sowmini Varadhan wrote:
On (08/05/18 08:59), Pavel Machek wrote:
quoted
Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
easily confused with Radio Data System (which we may want to support
in kernel, too).

I wonder if option should be named NET_RDS, instead?
RDS has been around for a while now (since 2.6). How will you
rename proposal manage backward compatibility? Why can't you call
your new option CONFIG_RADIO  or similar instead?

Are we going to rename NFS* to NET_NFS* because someone decided
to reuse the NFS acronym? 
Was it?

Because this was first time kernel asked that question... when I was
testing -next. Is this related?

commit 533d1daea8d8a389b37207ad7b50c4e750969231
    IB: Revert "remove redundant INFINIBAND kconfig dependencies"
quoted
And this sounds like a good idea:
-	tristate "The RDS Protocol"
+	tristate "The Reliable Datagram Sockets (RDS) Protocol"
surn that sounds fine.
Can you apply the patch, or do you want me to send it to davem?

Signed-off-by: Pavel Machek <redacted>

Thanks,
									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Re: [PATCH] RDS is not Radio Data System

From: Sowmini Varadhan <hidden>
Date: 2018-08-05 11:24:45

On (08/05/18 12:37), Pavel Machek wrote:
Was it?
RDS was added in 2.6.30: see  https://kernelnewbies.org/Linux_2_6_30

Recent RDS commits may have triggered the observation you note below
(you may have had it disabled by default until now)
Because this was first time kernel asked that question... when I was
testing -next. Is this related?
Can you apply the patch, or do you want me to send it to davem?
Signed-off-by: Pavel Machek <redacted>
please feel free to send the patch and add me as

Acked-by: Sowmini Varadhan <redacted>

--Sowmini

Re: [PATCH] RDS is not Radio Data System

From: santosh.shilimkar@oracle.com <hidden>
Date: 2018-08-06 03:42:07

On 8/4/18 11:59 PM, Pavel Machek wrote:
Hi!

Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
easily confused with Radio Data System (which we may want to support
in kernel, too).
Fair enough. Prompt change is fine Pavel.
I wonder if option should be named NET_RDS, instead?

And this sounds like a good idea:

(Plus, we normally have "module will be called foobar" and if unsure
say X. What happened to those?)
Module name is there for a while so please use different one if you
have a conflict with it.
quoted hunk
diff --git a/net/rds/Kconfig b/net/rds/Kconfig
index 41f7556..2738f14 100644
--- a/net/rds/Kconfig
+++ b/net/rds/Kconfig
@@ -1,6 +1,6 @@
  
  config RDS
-	tristate "The RDS Protocol"
+	tristate "The Reliable Datagram Sockets (RDS) Protocol"
  	depends on INET
  	---help---
  	  The RDS (Reliable Datagram Sockets) protocol provides reliable,
Please git format this patch with your SOB and send it to netdev.
Feel free to add my ack with it.

Acked-by: Santosh Shilimkar <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help