On 2018-03-04 10:01, Paul Moore wrote:
On Sat, Mar 3, 2018 at 4:19 AM, Serge E. Hallyn [off-list ref] wrote:
quoted
On Thu, Mar 01, 2018 at 02:41:04PM -0500, Richard Guy Briggs wrote:
...
quoted
+static inline bool audit_containerid_set(struct task_struct *tsk)
Hi Richard,
the calls to audit_containerid_set() confused me. Could you make it
is_audit_containerid_set() or audit_containerid_isset()?
I haven't gone through the entire patchset yet, but I wanted to
quickly comment on this ... I really dislike the
function-names-as-sentences approach and would would greatly prefer
audit_containerid_isset().
I'd be ok with this latter if necessary, but the naming mimics the
existing loginuid naming convention.
quoted
quoted
+{
+ return audit_get_containerid(tsk) != INVALID_CID;
+}
paul moore
- RGB
--
Richard Guy Briggs [off-list ref]
Sr. S/W Engineer, Kernel Security, Base Operating Systems
Remote, Ottawa, Red Hat Canada
IRC: rgb, SunRaycer
Voice: +1.647.777.2635, Internal: (81) 32635