On Wed, 24 Jan 2018 10:37:59 -0500 (EST), David Miller wrote:
From: Jakub Kicinski <redacted>
Date: Tue, 23 Jan 2018 18:45:58 -0800
quoted
Rename tc_cls_common_offload_init() to tc_cls_common_offload_init__()
and add a new implementation which also takes flags argument. We will
only set extack if flags indicate that offload is forced (skip_sw)
otherwise driver errors should be ignored, as they don't influence
the overall filter installation.
Note that we need the tc_skip_hw() helper for new version, therefore
it is added later in the file.
Signed-off-by: Jakub Kicinski <redacted>
Reviewed-by: Simon Horman <redacted>
Just give the old function a name which makes it's transient purpose
clear rather than this weird foo__() convention.
Something like tc_cls_common_offload_init_compat() or even
tc_cls_common_offload_init_deprecated().
Then people can say "oh, that is serving as a temporary compat
function until everyone is converted, then it is deleted"
Thanks.
Good point, I'll do that shortly.
Thank you!