Thread (17 messages) flat view 17 messages, 4 authors, 2018-01-24

Re: [PATCH net-next 02/12] net: sched: prepare for reimplementation of tc_cls_common_offload_init()

From: David Miller <davem@davemloft.net>
Date: 2018-01-24 15:38:01

From: Jakub Kicinski <redacted>
Date: Tue, 23 Jan 2018 18:45:58 -0800
Rename tc_cls_common_offload_init() to tc_cls_common_offload_init__()
and add a new implementation which also takes flags argument.  We will
only set extack if flags indicate that offload is forced (skip_sw)
otherwise driver errors should be ignored, as they don't influence
the overall filter installation.

Note that we need the tc_skip_hw() helper for new version, therefore
it is added later in the file.

Signed-off-by: Jakub Kicinski <redacted>
Reviewed-by: Simon Horman <redacted>
Just give the old function a name which makes it's transient purpose
clear rather than this weird foo__() convention.

Something like tc_cls_common_offload_init_compat() or even
tc_cls_common_offload_init_deprecated().

Then people can say "oh, that is serving as a temporary compat
function until everyone is converted, then it is deleted"

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help