On Tue, 25 Jul 2017 15:25:19 +0530, Sathya Perla wrote:
quoted
quoted
Suggested naming convention is "swXpYsZ", where X is the switch name or ID, Y
is the port name or ID, and Z is the sub-port name or ID. For example, sw1p1s0
would be sub-port 0 on port 1 on switch 1.
So for physical ports the convention is p<port_id>, and in case of
breakout p<port_id>s<subport_id>.
I'm sending a follow-up patch that fixes the naming for both the
external port and the VF-reps as proposed in your RFC ( switchdev:
clarify ndo_get_phys_port_name() formats)
Thanks!