Re: [PATCH net-next 3/6] net: dsa: mv88e6xxx: add a software reset op
From: Andrew Lunn <andrew@lunn.ch>
Date: 2016-12-02 15:44:10
Also in:
lkml
On Thu, Dec 01, 2016 at 03:41:20PM -0500, Vivien Didelot wrote:
Hi Andrew, Andrew Lunn [off-list ref] writes:quoted
quoted
diff --git a/drivers/net/dsa/mv88e6xxx/mv88e6xxx.h b/drivers/net/dsa/mv88e6xxx/mv88e6xxx.h index ab52c37..9e51405 100644 --- a/drivers/net/dsa/mv88e6xxx/mv88e6xxx.h +++ b/drivers/net/dsa/mv88e6xxx/mv88e6xxx.h@@ -765,6 +765,9 @@ struct mv88e6xxx_ops { int (*phy_write)(struct mv88e6xxx_chip *chip, int addr, int reg, u16 val); + /* Switch Software Reset */ + int (*reset)(struct mv88e6xxx_chip *chip); +Hi Vivien In my huge patch series of 6390, i've been using a g1_ prefix for functionality which is in global 1, g2_ for global 2, etc. This has worked for everything so far with the exception of setting which reserved MAC addresses should be sent to the CPU. Most devices have it in g2, but 6390 has it in g1. Please could you add the prefix.I don't understand. It looks like you are talking about the second part of the comment I made on your RFC patchset, about the Rsvd2CPU feature:
Hi Vivien I mean + /* Switch Software Reset */ + int (*g1_reset)(struct mv88e6xxx_chip *chip); + We have a collection of function pointers with port_ prefix, another collection with stats_, and a third with ppu_, etc. And then we have some which do not fit a specific category. Those i have prefixed with g1_ or g2_. I think we should have some prefix, and that is my suggestion. Andrew