On Tue, Oct 18, 2016 at 01:27:30PM +0200, Stefan Wahren wrote:
As preparation for the upcoming UART driver we need a module
which contains common functions for both interfaces. The module
qca_framing is a good candidate but renaming to qca_common would
make it clear.
Signed-off-by: Stefan Wahren <redacted>
---
drivers/net/ethernet/qualcomm/Makefile | 2 +-
drivers/net/ethernet/qualcomm/qca_common.c | 156 ++++++++++++++++++++++++++++
drivers/net/ethernet/qualcomm/qca_common.h | 134 ++++++++++++++++++++++++
drivers/net/ethernet/qualcomm/qca_framing.c | 156 ----------------------------
drivers/net/ethernet/qualcomm/qca_framing.h | 134 ------------------------
drivers/net/ethernet/qualcomm/qca_spi.c | 2 +-
drivers/net/ethernet/qualcomm/qca_spi.h | 2 +-
7 files changed, 293 insertions(+), 293 deletions(-)
create mode 100644 drivers/net/ethernet/qualcomm/qca_common.c
create mode 100644 drivers/net/ethernet/qualcomm/qca_common.h
delete mode 100644 drivers/net/ethernet/qualcomm/qca_framing.c
delete mode 100644 drivers/net/ethernet/qualcomm/qca_framing.h
'git format-patch -M' is nice when renaming files to show that the files
really are being renamed, and no other changes are being made (or show
the changes easier.)
thanks,
greg k-h