Hi,
On Tue, 27 Sep 2016 12:30:20 +0200 Daniel Borkmann [off-list ref] wrote:
On 09/22/2016 03:21 PM, Shmulik Ladkani wrote:
quoted
From: Shmulik Ladkani <redacted>
'tcfm_ok_push' specifies whether a mac_len sized push is needed upon
egress to the target device (if action is performed at ingress).
Rename it to 'tcfm_mac_header_xmit' as this is actually an attribute of
the target device.
This allows to decouple the attribute from the action to be taken.
Signed-off-by: Shmulik Ladkani <redacted>
---
include/net/tc_act/tc_mirred.h | 2 +-
net/sched/act_mirred.c | 10 +++++-----
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/include/net/tc_act/tc_mirred.h b/include/net/tc_act/tc_mirred.h
index 62770ad..5275158 100644
--- a/include/net/tc_act/tc_mirred.h
+++ b/include/net/tc_act/tc_mirred.h
@@ -8,7 +8,7 @@ struct tcf_mirred {
struct tc_action common;
int tcfm_eaction;
int tcfm_ifindex;
- int tcfm_ok_push;
+ int tcfm_mac_header_xmit;
Since you already touch this here and in patch 2/4 anyway, maybe
make that a bool along the way?
Ok.
(Thought of it, but my urge to lessen the diff eventually won)
Perhaps instead of tcfm_mac_header_xmit, tcfm_mac_header_push
might be a better name?
Don't think so.
Eventually this serves as the decision to either push or pull, so prefer
not to name it as the action (push/pull) but rather what is target
device's property (xmits at mh?).