Thread (30 messages) flat view 30 messages, 3 authors, 2016-06-14

Re: [PATCH v2 net-next v2 05/12] net: dsa: mv88e6xxx: add switch register helpers

From: Andrew Lunn <andrew@lunn.ch>
Date: 2016-06-14 21:17:26
Also in: lkml

On Tue, Jun 14, 2016 at 02:31:46PM -0400, Vivien Didelot wrote:
The mixed assignments, allocations and registrations in the probe code
make it hard to follow the logic and figure out what is DSA or chip
specific.

Extract the struct dsa_switch related code in a simple
mv88e6xxx_register_switch helper function.

For symmetry in the code, add a mv88e6xxx_unregister_switch function.

Signed-off-by: Vivien Didelot <redacted>
Reviewed-by: Andrew Lunn <andrew@lunn.ch>

    Andrew
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help