Re: [Patch net-next] net_sched: add network namespace support for tc actions
From: Cong Wang <hidden>
Date: 2016-02-22 23:51:52
On Mon, Feb 22, 2016 at 5:42 AM, Jamal Hadi Salim [off-list ref] wrote:
I did a quick look and i am struggling with it. The patch seems largish The issue is that we need to do this per kernel module so the code churn maybe unavoidable; hinfo stored in act_ops complicates things. Having said that: All the pernet operations in your code seem to be generic, other than to accomodate for module specific act_ops. Is it possible to make generic pernet operations? This way you could do things at tcf_register_action() for all actions. The challenge seems to be in the xxx_net_id which appears(sorry didnt look closely at the namespace code) to need to be unique id per module and per namespace instance - otherwise i would suggest for xxx_net_id
I got some idea to reduce the duplicated code, not all but most.
to be part of act_ops. Could we not have an #ifdef in the namespace core like the netfilter code does and have one level of indirection for everything but the namespace 0?
I believe this should be done in a separated patch if really needed. Thanks.