Thread (5 messages) flat view 5 messages, 3 authors, 2016-02-22

Re: [Patch net-next] net_sched: add network namespace support for tc actions

From: Cong Wang <hidden>
Date: 2016-02-21 00:46:06

On Sat, Feb 20, 2016 at 10:36 AM, Daniel Borkmann [off-list ref] wrote:
Do you see a way to reduce the code duplication needed across all
the action modules? I.e. that each of them now needs to register
a new per netns subsystem, etc. In other words, is there a way the
action API could be reworked to handle most of this in the tc core
framework instead?
I definitely agree.

Initially I made a wrapper macro for the per netns API for each tc
action, but it didn't work as I thought, mostly due to the per net ops and
net_id stuffs.

So it is not as easy as it appears, it needs more work. At least the
current code is more readable than using any macro. We can always
refactor the API in the future, and as I mentioned in the changelog that
is in my plan.

Or do you have any quick and easy way to reduce the code?

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help