Thread (23 messages) 23 messages, 4 authors, 2015-09-22

Re: [patch net-next RFC 3/6] rocker: switch to local transaction phase enum

flat view

From: Jiri Pirko <jiri@resnulli.us>
Date: 2015-09-20 08:59:23

Sat, Sep 19, 2015 at 09:25:04PM CEST, vivien.didelot@savoirfairelinux.com wrote:
Hi Jiri,

On Sep. Saturday 19 (38) 02:29 PM, Jiri Pirko wrote:
quoted
Since switchdev_trans_ph anum is going to be removed, and rocker code is
way too complicated in this matter to be converted, just introduce local
enum for transaction phase. Pass it around in local transaction
structure.
I missed this typo here: s/anum/enum/.
quoted
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
I found the renaming trick is a bit hard to follow. I am wondering if
this patch could be used first and drop patch 1/6?

That way, you can first add the rocker_trans structure and set its ph
member to obj->trans in obj_add/attr_set, then the following patch
(currently 2/6) would just assign it to the new trans parameter.
That could work locally for rocker, but for the rest of the code, I
belive it would not. Anyway, the result would be the same.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help