Hi Jiri,
On Sep. Saturday 19 (38) 02:29 PM, Jiri Pirko wrote:
Since switchdev_trans_ph anum is going to be removed, and rocker code is
way too complicated in this matter to be converted, just introduce local
enum for transaction phase. Pass it around in local transaction
structure.
I missed this typo here: s/anum/enum/.
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
I found the renaming trick is a bit hard to follow. I am wondering if
this patch could be used first and drop patch 1/6?
That way, you can first add the rocker_trans structure and set its ph
member to obj->trans in obj_add/attr_set, then the following patch
(currently 2/6) would just assign it to the new trans parameter.
Thanks,
-v